1PHP_ARG_WITH([xsl],
2  [whether to build with XSL support],
3  [AS_HELP_STRING([--with-xsl],
4    [Build with XSL support])])
5
6if test "$PHP_XSL" != "no"; then
7
8  if test "$PHP_LIBXML" = "no"; then
9    AC_MSG_ERROR([XSL extension requires LIBXML extension, add --with-libxml])
10  fi
11
12  if test "$PHP_DOM" = "no"; then
13    AC_MSG_ERROR([XSL extension requires DOM extension, add --enable-dom])
14  fi
15
16  PKG_CHECK_MODULES([XSL], [libxslt >= 1.1.0])
17
18  PHP_EVAL_INCLINE($XSL_CFLAGS)
19  PHP_EVAL_LIBLINE($XSL_LIBS, XSL_SHARED_LIBADD)
20
21  PKG_CHECK_MODULES([EXSLT], [libexslt],
22  [
23    PHP_EVAL_INCLINE($EXSLT_CFLAGS)
24    PHP_EVAL_LIBLINE($EXSLT_LIBS, XSL_SHARED_LIBADD)
25    AC_DEFINE(HAVE_XSL_EXSLT, 1, [ ])
26  ], [ ])
27
28  AC_DEFINE(HAVE_XSL,1,[ ])
29  PHP_NEW_EXTENSION(xsl, php_xsl.c xsltprocessor.c, $ext_shared)
30  PHP_SUBST(XSL_SHARED_LIBADD)
31  PHP_ADD_EXTENSION_DEP(xsl, libxml)
32fi
33